package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((\+?234)|0)([89]((0[0-9])|(1[0-9]))|([79]0[1-9]))[0-9]{7}$`)
var str = `08064443187`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}