import re
regex = re.compile(r"^((\+?234)|0)([89]((0[0-9])|(1[0-9]))|([79]0[1-9]))[0-9]{7}$", flags=re.MULTILINE)
test_str = "08064443187"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")