$re = '/^((\+?234)|0)([89]((0[0-9])|(1[0-9]))|([79]0[1-9]))[0-9]{7}$/m';
$str = '08064443187';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);