re = /^((\+?234)|0)([89]((0[0-9])|(1[0-9]))|([79]0[1-9]))[0-9]{7}$/m
str = '08064443187'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end