using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""(/catalog/[0-9]+(?:\?bxrand=[0-9]+)?/)";
string input = @"href=""/catalog/12338?bxrand=1603877224798/0/""
href=""/catalog/12338/0/""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}