$re = '~href="(/catalog/[0-9]+(?:\?bxrand=[0-9]+)?/)~m';
$str = 'href="/catalog/12338?bxrand=1603877224798/0/"
href="/catalog/12338/0/"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);