const regex = new RegExp('href="(/catalog/[0-9]+(?:\\?bxrand=[0-9]+)?/)', 'gm')
const str = `href="/catalog/12338?bxrand=1603877224798/0/"
href="/catalog/12338/0/"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}