re = /href="(\/catalog\/[0-9]+(?:\?bxrand=[0-9]+)?\/)/m
str = 'href="/catalog/12338?bxrand=1603877224798/0/"
href="/catalog/12338/0/"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end