package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)href="(/catalog/[0-9]+(?:\?bxrand=[0-9]+)?/)`)
var str = `href="/catalog/12338?bxrand=1603877224798/0/"
href="/catalog/12338/0/"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}