package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d*day-(.*?)--.*`)
var str = `2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv`
var substitution = "\1"
fmt.Println(re.ReplaceAllString(str, substitution))
}