import re
regex = re.compile(r"\d*day-(.*?)--.*", flags=re.MULTILINE)
test_str = ("2day-2023-1-5--20-0.csv\n"
"1day-2023-2-5--20-0.csv\n"
"3day-2021-1-5--20-0.csv")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)