import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d*day-(.*?)--.*";
final String string = "2day-2023-1-5--20-0.csv\n"
+ "1day-2023-2-5--20-0.csv\n"
+ "3day-2021-1-5--20-0.csv";
final String subst = "\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}