// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\d*day-(.*?)--.*").unwrap();
let string = "2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}