$re = '/\d*day-(.*?)--.*/m';
$str = '2day-2023-1-5--20-0.csv
1day-2023-2-5--20-0.csv
3day-2021-1-5--20-0.csv';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;