import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\s*img[^>]*?src\\s*=\\s*([\"'])([^\"']+)\\1[^>]*?>";
final String string = "<img src = \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg\">\n"
+ "< img src= \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg\">\n"
+ "<img src =\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg\">\n"
+ "<img src=\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg\">\n"
+ "<img src =\"file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg\">\n"
+ "<img src= \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">\n"
+ "<img src=\n"
+ " \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">\n"
+ "<img\n"
+ " src=\n"
+ " \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">\n"
+ "< \n"
+ "img\n"
+ " src=\n"
+ " \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">\n"
+ "< \n"
+ "img\n"
+ " src\n"
+ "=\n"
+ " \"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg\">";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}