use strict;
my $str = '<img src = "file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg">
< img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg">
<img src="file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg">
<img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<img src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<img
src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<
img
src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<
img
src
=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">';
my $regex = qr/<\s*img[^>]*?src\s*=\s*(["'])([^"']+)\1[^>]*?>/iup;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";