import Foundation
// WARNING: You included a flag that Swift doesn't support: u
// When this flag is set, it makes the pattern and subject strings to be treated as unicode.
// Swift already treats the pattern and subject strings as unicode by default, so including this flag is redundant.
let pattern = #"<\s*img[^>]*?src\s*=\s*(["'])([^"']+)\1[^>]*?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .caseInsensitive)
let testString = #"""
<img src = "file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg">
< img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg">
<img src="file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg">
<img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<img src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<img
src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<
img
src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<
img
src
=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)