$re = '/<\s*img[^>]*?src\s*=\s*(["\'])([^"\']+)\1[^>]*?>/iu';
$str = '<img src = "file:/D:/Tomato/IdeaProjects/TheSUD2/photo.jpg">
< img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo1.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo2.jpg">
<img src="file:/D:/Tomato/IdeaProjects/TheSUD2/photo3.jpg">
<img src ="file:/D:/Tomato/IdeaProjects/TheSUD2/photo4.jpg">
<img src= "file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<img src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<img
src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<
img
src=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">
<
img
src
=
"file:/D:/Tomato/IdeaProjects/TheSUD2/photo5.jpg">';
$subst = "$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;