#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2}/\d{2})\s+([^-+]*)\s+([-+]?)\s?(\d{1,3}(?:\.\d{3})*(?:,\d+)?)\s+(.*)?"
Local $sString = "16/04 RC GRACAS 2 - 0,02" & @CRLF & _
"SAÚDE .RECIFE" & @CRLF & _
"" & @CRLF & _
"16/04 RC GRACAS 2 02/03 45,97" & @CRLF & _
"SAÚDE .RECIFE" & @CRLF & _
"" & @CRLF & _
"12/12 - 23" & @CRLF & _
"No description, negative value" & @CRLF & _
"" & @CRLF & _
"12/12 23" & @CRLF & _
"No description, unsigned value" & @CRLF & _
"" & @CRLF & _
"12/12 + 23" & @CRLF & _
"No description, positive value" & @CRLF & _
"" & @CRLF & _
"12/12 A description that contains a - hyphen - 14" & @CRLF & _
"with negative number" & @CRLF & _
"" & @CRLF & _
"12/12 A description that contains a + plus + 14" & @CRLF & _
"with positive number" & @CRLF & _
"" & @CRLF & _
"12/12 Adjacent hyphens - - 1" & @CRLF & _
"with negative number" & @CRLF & _
"" & @CRLF & _
"12/12 Adjacent pluses + + 1" & @CRLF & _
"with positive number" & @CRLF & _
"" & @CRLF & _
"12/12 Adjacent hyphens -- 1" & @CRLF & _
"with no space" & @CRLF & _
"" & @CRLF & _
"12/12 Adjacent pluses++ 1" & @CRLF & _
"with no space" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")