import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\d{2}/\\d{2})\\s+([^-+]*)\\s+([-+]?)\\s?(\\d{1,3}(?:\\.\\d{3})*(?:,\\d+)?)\\s+(.*)?";
final String string = "16/04 RC GRACAS 2 - 0,02\n"
+ "SAÚDE .RECIFE\n\n"
+ "16/04 RC GRACAS 2 02/03 45,97\n"
+ "SAÚDE .RECIFE\n\n"
+ "12/12 - 23\n"
+ "No description, negative value\n\n"
+ "12/12 23\n"
+ "No description, unsigned value\n\n"
+ "12/12 + 23\n"
+ "No description, positive value\n\n"
+ "12/12 A description that contains a - hyphen - 14\n"
+ "with negative number\n\n"
+ "12/12 A description that contains a + plus + 14\n"
+ "with positive number\n\n"
+ "12/12 Adjacent hyphens - - 1\n"
+ "with negative number\n\n"
+ "12/12 Adjacent pluses + + 1\n"
+ "with positive number\n\n"
+ "12/12 Adjacent hyphens -- 1\n"
+ "with no space\n\n"
+ "12/12 Adjacent pluses++ 1\n"
+ "with no space\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}