import Foundation
let pattern = #"^(\d{2}/\d{2})\s+([^-+]*)\s+([-+]?)\s?(\d{1,3}(?:\.\d{3})*(?:,\d+)?)\s+(.*)?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
12/12 - 23
No description, negative value
12/12 23
No description, unsigned value
12/12 + 23
No description, positive value
12/12 A description that contains a - hyphen - 14
with negative number
12/12 A description that contains a + plus + 14
with positive number
12/12 Adjacent hyphens - - 1
with negative number
12/12 Adjacent pluses + + 1
with positive number
12/12 Adjacent hyphens -- 1
with no space
12/12 Adjacent pluses++ 1
with no space
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)