// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(\d{2}/\d{2})\s+([^-+]*)\s+([-+]?)\s?(\d{1,3}(?:\.\d{3})*(?:,\d+)?)\s+(.*)?").unwrap();
let string = "16/04 RC GRACAS 2 - 0,02
SAÚDE .RECIFE
16/04 RC GRACAS 2 02/03 45,97
SAÚDE .RECIFE
12/12 - 23
No description, negative value
12/12 23
No description, unsigned value
12/12 + 23
No description, positive value
12/12 A description that contains a - hyphen - 14
with negative number
12/12 A description that contains a + plus + 14
with positive number
12/12 Adjacent hyphens - - 1
with negative number
12/12 Adjacent pluses + + 1
with positive number
12/12 Adjacent hyphens -- 1
with no space
12/12 Adjacent pluses++ 1
with no space
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}