# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\d{2}/\d{2})\s+([^-+]*)\s+([-+]?)\s?(\d{1,3}(?:\.\d{3})*(?:,\d+)?)\s+(.*)?"
test_str = ("16/04 RC GRACAS 2 - 0,02\n"
"SAÚDE .RECIFE\n\n"
"16/04 RC GRACAS 2 02/03 45,97\n"
"SAÚDE .RECIFE\n\n"
"12/12 - 23\n"
"No description, negative value\n\n"
"12/12 23\n"
"No description, unsigned value\n\n"
"12/12 + 23\n"
"No description, positive value\n\n"
"12/12 A description that contains a - hyphen - 14\n"
"with negative number\n\n"
"12/12 A description that contains a + plus + 14\n"
"with positive number\n\n"
"12/12 Adjacent hyphens - - 1\n"
"with negative number\n\n"
"12/12 Adjacent pluses + + 1\n"
"with positive number\n\n"
"12/12 Adjacent hyphens -- 1\n"
"with no space\n\n"
"12/12 Adjacent pluses++ 1\n"
"with no space\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.