# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"service\-(?P<serviceName>[a-zA-Z]+[a-zA-Z-]+[a-zA-Z]+)\-v(?P<versionMajor>[0-9]+)\.(?P<versionMinor>[0-9]+)\.(?P<versionPatch>[0-9]+)(?:\-(?P<versionType>alpha|beta|rc)(?:\.(?P<versionTypeNumber>[0-9]+)))?\.(?P<fileExt>gtw)"
test_str = ("service-bad-v1.0.0-ddd.1.gtw\n"
"service-bad-v.0.0.gtw\n"
"service-bad-v1..0.gtw\n"
"service-bad-1.0.0.gtw\n"
"service-bad-cool--v1.0.0-alpha.1.gtw\n"
"service--bad-cool-v1.0.0-alpha.1.gtw\n"
"service-user-v1.0.0\n"
"service-user-v1.0.0-alpha.1\n"
"service-channel-cool-v1.0.0-alpha.1\n"
"service-user-v1.0.0.gtw\n"
"service-user-v1.0.0-alpha.1.gtw\n"
"service-channel-cool-v1.0.0-alpha.1.gtw")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.