#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?u)(?i)\b(\d{1,2}):(\d{2})\h*(a|p)\.?m\.?"
Local $sString = "event1,2020-03-26,7:00 am - 9:00 pm,location1" & @CRLF & _
"event2,2020-03-28,11:05 A.M. - 12:34 pm,location2"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")