using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)\b(\d{1,2}):(\d{2})\h*(a|p)\.?m\.?";
string input = @"event1,2020-03-26,7:00 am - 9:00 pm,location1
event2,2020-03-28,11:05 A.M. - 12:34 pm,location2";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}