import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)\\b(\\d{1,2}):(\\d{2})\\h*(a|p)\\.?m\\.?";
final String string = "event1,2020-03-26,7:00 am - 9:00 pm,location1\n"
+ "event2,2020-03-28,11:05 A.M. - 12:34 pm,location2";
final Pattern pattern = Pattern.compile(regex, Pattern.UNICODE_CASE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}