const regex = /(?i)\b(\d{1,2}):(\d{2})\h*(a|p)\.?m\.?/gu;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)\\b(\\d{1,2}):(\\d{2})\\h*(a|p)\\.?m\\.?', 'gu')
const str = `event1,2020-03-26,7:00 am - 9:00 pm,location1
event2,2020-03-28,11:05 A.M. - 12:34 pm,location2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}