$re = '/(?i)\b(\d{1,2}):(\d{2})\h*(a|p)\.?m\.?/u';
$str = 'event1,2020-03-26,7:00 am - 9:00 pm,location1
event2,2020-03-28,11:05 A.M. - 12:34 pm,location2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);