import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?!\\[)[\\d\\-]+(?=\\]))|((?!\\[)\\{\\{[\\w-_]*\\}\\}=[\\d-]+(?=\\]))";
final String string = "Date format: [2017-10-27] or [{{variable-name}}=2017-10-27]\n\n"
+ "//match the date format [YYYY-MM-DD] or [{{variable-name}}=YYYY-MM-DD] for datepicker, but filter out \"Square Brackets[]\" at the same time? ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}