use strict;
my $str = 'Date format: [2017-10-27] or [{{variable-name}}=2017-10-27]
//match the date format [YYYY-MM-DD] or [{{variable-name}}=YYYY-MM-DD] for datepicker, but filter out "Square Brackets[]" at the same time? ';
my $regex = qr/((?!\[)[\d\-]+(?=\]))|((?!\[){{[\w-_]*}}=[\d-]+(?=\]))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}