$re = '/((?!\[)[\d\-]+(?=\]))|((?!\[){{[\w-_]*}}=[\d-]+(?=\]))/';
$str = 'Date format: [2017-10-27] or [{{variable-name}}=2017-10-27]
//match the date format [YYYY-MM-DD] or [{{variable-name}}=YYYY-MM-DD] for datepicker, but filter out "Square Brackets[]" at the same time? ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);