import Foundation
let pattern = #"((?!\[)[\d\-]+(?=\]))|((?!\[){{[\w-_]*}}=[\d-]+(?=\]))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Date format: [2017-10-27] or [{{variable-name}}=2017-10-27]
//match the date format [YYYY-MM-DD] or [{{variable-name}}=YYYY-MM-DD] for datepicker, but filter out "Square Brackets[]" at the same time?
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)