#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?=(K[DE]|[DE]K))"
Local $sString = "KD" & @CRLF & _
"KE" & @CRLF & _
"EK" & @CRLF & _
"DK" & @CRLF & _
"KDK" & @CRLF & _
"KEK" & @CRLF & _
"EKE" & @CRLF & _
"DKD" & @CRLF & _
"EKD" & @CRLF & _
"DKE" & @CRLF & _
"KDKD" & @CRLF & _
"KDKE" & @CRLF & _
"KDDK" & @CRLF & _
"KEEK" & @CRLF & _
"KEEKE" & @CRLF & _
"KDDDK"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")