re = /(?=(K[DE]|[DE]K))/
str = 'KD
KE
EK
DK
KDK
KEK
EKE
DKD
EKD
DKE
KDKD
KDKE
KDDK
KEEK
KEEKE
KDDDK'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end