import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(K[DE]|[DE]K))";
final String string = "KD\n"
+ "KE\n"
+ "EK\n"
+ "DK\n"
+ "KDK\n"
+ "KEK\n"
+ "EKE\n"
+ "DKD\n"
+ "EKD\n"
+ "DKE\n"
+ "KDKD\n"
+ "KDKE\n"
+ "KDDK\n"
+ "KEEK\n"
+ "KEEKE\n"
+ "KDDDK";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}