const regex = /(?=(K[DE]|[DE]K))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=(K[DE]|[DE]K))', 'g')
const str = `KD
KE
EK
DK
KDK
KEK
EKE
DKD
EKD
DKE
KDKD
KDKE
KDDK
KEEK
KEEKE
KDDDK`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}