$re = '/(?=(K[DE]|[DE]K))/';
$str = 'KD
KE
EK
DK
KDK
KEK
EKE
DKD
EKD
DKE
KDKD
KDKE
KDDK
KEEK
KEEKE
KDDDK';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);