#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)<!ATTLIST\s*" & @CRLF & _
"(?'elname'\S+)\s*" & @CRLF & _
"(?'attr'" & @CRLF & _
" (?'attrName'[-_A-Za-z0-9]+)" & @CRLF & _
" \s+" & @CRLF & _
" (?'declVal'" & @CRLF & _
" (?'attrEnum'\([\s\-_|A-Za-z0-9]+\)) | " & @CRLF & _
" (?'attrType'[-_A-Za-z0-9]+)" & @CRLF & _
" )" & @CRLF & _
" (?'default'\s+" & @CRLF & _
" (?'defType'(\#[A-Z]+))?\s*" & @CRLF & _
" (?'defVal'['""][-_A-Za-z0-9]+['""][\s*>])?" & @CRLF & _
" )?\s*" & @CRLF & _
")+" & @CRLF & _
">"
Local $sString = "<!ATTLIST ELNAME" & @CRLF & _
" CHOICETYPE (MUTUALLY-EXCLUSIVE | NONEXCLUSIVE) #IMPLIED" & @CRLF & _
" EMODARCH NAME #FIXED "EFFECTIVITY-CHOICE"" & @CRLF & _
" RULESPEC NAME #IMPLIED" & @CRLF & _
" RULESPEC-SUPPL NUMBER #IMPLIED" & @CRLF & _
" EID NAME #REQUIRED" & @CRLF & _
" DTD-VERSION CDATA #FIXED '2016-04-05-BETA-DRAFT1'" & @CRLF & _
" BID NAME #IMPLIED>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")