// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?mx)<!ATTLIST\s*
(?'elname'\S+)\s*
(?'attr'
(?'attrName'[-_A-Za-z0-9]+)
\s+
(?'declVal'
(?'attrEnum'\([\s\-_|A-Za-z0-9]+\)) |
(?'attrType'[-_A-Za-z0-9]+)
)
(?'default'\s+
(?'defType'(\#[A-Z]+))?\s*
(?'defVal'['""][-_A-Za-z0-9]+['""][\s*>])?
)?\s*
)+
>"#).unwrap();
let string = "<!ATTLIST ELNAME
CHOICETYPE (MUTUALLY-EXCLUSIVE | NONEXCLUSIVE) #IMPLIED
EMODARCH NAME #FIXED \"EFFECTIVITY-CHOICE\"
RULESPEC NAME #IMPLIED
RULESPEC-SUPPL NUMBER #IMPLIED
EID NAME #REQUIRED
DTD-VERSION CDATA #FIXED '2016-04-05-BETA-DRAFT1'
BID NAME #IMPLIED>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}