using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!ATTLIST\s*
(?'elname'\S+)\s*
(?'attr'
(?'attrName'[-_A-Za-z0-9]+)
\s+
(?'declVal'
(?'attrEnum'\([\s\-_|A-Za-z0-9]+\)) |
(?'attrType'[-_A-Za-z0-9]+)
)
(?'default'\s+
(?'defType'(\#[A-Z]+))?\s*
(?'defVal'['""][-_A-Za-z0-9]+['""][\s*>])?
)?\s*
)+
>";
string input = @"<!ATTLIST ELNAME
CHOICETYPE (MUTUALLY-EXCLUSIVE | NONEXCLUSIVE) #IMPLIED
EMODARCH NAME #FIXED ""EFFECTIVITY-CHOICE""
RULESPEC NAME #IMPLIED
RULESPEC-SUPPL NUMBER #IMPLIED
EID NAME #REQUIRED
DTD-VERSION CDATA #FIXED '2016-04-05-BETA-DRAFT1'
BID NAME #IMPLIED>";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}