import re
regex = re.compile(r"""
<!ATTLIST\s*
(?'elname'\S+)\s*
(?'attr'
(?'attrName'[-_A-Za-z0-9]+)
\s+
(?'declVal'
(?'attrEnum'\([\s\-_|A-Za-z0-9]+\)) |
(?'attrType'[-_A-Za-z0-9]+)
)
(?'default'\s+
(?'defType'(\#[A-Z]+))?\s*
(?'defVal'['""][-_A-Za-z0-9]+['""][\s*>])?
)?\s*
)+
>
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("<!ATTLIST ELNAME\n"
" CHOICETYPE (MUTUALLY-EXCLUSIVE | NONEXCLUSIVE) #IMPLIED\n"
" EMODARCH NAME #FIXED \"EFFECTIVITY-CHOICE\"\n"
" RULESPEC NAME #IMPLIED\n"
" RULESPEC-SUPPL NUMBER #IMPLIED\n"
" EID NAME #REQUIRED\n"
" DTD-VERSION CDATA #FIXED '2016-04-05-BETA-DRAFT1'\n"
" BID NAME #IMPLIED>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")