package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<!ATTLIST\s*
(?'elname'\S+)\s*
(?'attr'
(?'attrName'[-_A-Za-z0-9]+)
\s+
(?'declVal'
(?'attrEnum'\([\s\-_|A-Za-z0-9]+\)) |
(?'attrType'[-_A-Za-z0-9]+)
)
(?'default'\s+
(?'defType'(\#[A-Z]+))?\s*
(?'defVal'['""][-_A-Za-z0-9]+['""][\s*>])?
)?\s*
)+
>`)
var str = `<!ATTLIST ELNAME
CHOICETYPE (MUTUALLY-EXCLUSIVE | NONEXCLUSIVE) #IMPLIED
EMODARCH NAME #FIXED "EFFECTIVITY-CHOICE"
RULESPEC NAME #IMPLIED
RULESPEC-SUPPL NUMBER #IMPLIED
EID NAME #REQUIRED
DTD-VERSION CDATA #FIXED '2016-04-05-BETA-DRAFT1'
BID NAME #IMPLIED>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}