import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((?<=cachorro )corre\\w+|(?<=cachorro )foi|(?<=cachorro )pul\\w+)";
final String string = "O cachorro correu com o gato\n"
+ "O carro passou e o cachorro foi atrás\n"
+ "Sempre que chego em casa meu cachorro pula em mim\n"
+ "Ele foi correndo atrás do sonho\n"
+ "Enquanto o gato correu\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}