const regex = /((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<=cachorro )corre\\w+|(?<=cachorro )foi|(?<=cachorro )pul\\w+)', 'g')
const str = `O cachorro correu com o gato
O carro passou e o cachorro foi atrás
Sempre que chego em casa meu cachorro pula em mim
Ele foi correndo atrás do sonho
Enquanto o gato correu
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}