import Foundation
let pattern = #"((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
O cachorro correu com o gato
O carro passou e o cachorro foi atrás
Sempre que chego em casa meu cachorro pula em mim
Ele foi correndo atrás do sonho
Enquanto o gato correu
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)