$re = '/((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)/';
$str = 'O cachorro correu com o gato
O carro passou e o cachorro foi atrás
Sempre que chego em casa meu cachorro pula em mim
Ele foi correndo atrás do sonho
Enquanto o gato correu
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);