re = /((?<=cachorro )corre\w+|(?<=cachorro )foi|(?<=cachorro )pul\w+)/
str = 'O cachorro correu com o gato
O carro passou e o cachorro foi atrás
Sempre que chego em casa meu cachorro pula em mim
Ele foi correndo atrás do sonho
Enquanto o gato correu
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end