using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)(?=.*\b^From:\s*\b)(?=.*\bwilliam\b)(?=.*\brhodes\b).*";
string input = @"To: bill.rhodes@autozone.com
from: William rhodes
from: william.rhodes
From:willIAM.T.Rhodes
FROM: William C. Rhodes
from: WIlam Rhodes <william.rhodes@company.com)
from: Rhodes, WIlliam
from: rhodes.william@company.com
from: william.rhodes@company.com
From: ""Rhodes, William"" <william.rhodes@somecompany.com>
From: Rhodes, William <william.rhodes@somecompany.com>
From:
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}