$re = '/(?i)(?=.*\b^From:\s*\b)(?=.*\bwilliam\b)(?=.*\brhodes\b).*/m';
$str = 'To: bill.rhodes@autozone.com
from: William rhodes
from: william.rhodes
From:willIAM.T.Rhodes
FROM: William C. Rhodes
from: WIlam Rhodes <william.rhodes@company.com)
from: Rhodes, WIlliam
from: rhodes.william@company.com
from: william.rhodes@company.com
From: "Rhodes, William" <william.rhodes@somecompany.com>
From: Rhodes, William <william.rhodes@somecompany.com>
From:
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);